
 
 
 
 

 
 

FileSurf / Hummingbird DM 
Installation and Configuration 
Manual 
 
 
Prepared:  March 2005 
Version: FS75 SR3 HF1 
 
 
MDY Advanced Technologies, Inc. 



 

 
FileSurf/Hummingbird DM 5 
Installation and Configuration Guide 
 

Page 2 of 41 Confidential 

 

 

Table of Contents 
 
1 Design ......................................................................................................................... 3 

1.1 Supported Products ................................................................................... 3 
2 Prerequisites .......................................................................................................... 3 
3 Manual Installation............................................................................................. 4 

3.1 Summary of Tasks....................................................................................... 4 
3.2 On the Database Server........................................................................... 5 
3.3 On the FileSurf Web Server ................................................................. 23 
3.4 On the client ................................................................................................. 27 

4 Configuration........................................................................................................ 28 
4.1 Fields Mapping ............................................................................................ 30 

4.1.1 Introduction ......................................................................................... 30 
4.1.2 Mapping Fields Between FileSurf & Hummingbird DM30 

4.2 Matrix................................................................................................................ 32 
4.2.1 Introduction ......................................................................................... 32 

Appendix: Installing DM Extensions on FileSurf Server................. 35 
  



 

 
FileSurf/Hummingbird DM 5 
Installation and Configuration Guide 
 

Page 3 of 41 Confidential 

 

 
Welcome to the installation and configuration guide for FileSurf – 
Hummingbird DM integration from MDY.  The FileSurf-Hummingbird DM 
integration facilitates the sharing of data between FileSurf and 
Hummingbird’s DM document management product.  Please read the entire 
document before proceeding with the installation. 
 

1 Design 
1.1 Supported Products 
The MDY integration of FileSurf and Hummingbird's DM supports the 
following products only: 

• FileSurf 7.5 service release 3 

• Hummingbird DM Server 5.1.0.5 

• Hummingbird DM 5.1.0.5 

 

2 Prerequisites 
• The following should be installed and working prior to installing the 

integration: 

Hummingbird DM Server 

Microsoft Windows 

Fusion Service 

 

FileSurf Server 

Microsoft Windows 

FileSurf COM Server 

Hummingbird DM Extensions  

Windows Explorer DM Extension 

 

Client  

Microsoft Windows 

Hummingbird DM client 

FileSurf client 

The above products have their own requirements which might coincide 
or differ from the integration's.  Please refer to the individual software 
for specific requirements. 
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• FileSurf Admin account is a Hummingbird DM user with administrative 
privileges plus the ability to delete versions.  Details on adding the 
FileSurf Admin account can be found in the installation section 

• Metadata synchronization requires two DM groups, FILESURF_USERS 
and FILESURF_SUPERUSERS.  If metadata synchronization is not to be 
used, they are not necessary.  Metadata synchronization will create 
these groups if it finds that they do not exist.  If not using Metadata 
synchronization, the users will need to be added manually.  FileSurf 
checks FILESURF_USERS to see if integration is available to user. 

• FileSurf and Hummingbird users and groups synchronized. 

• The Hummingbird initialization file, PCDOCS.INI, should be in the 
FileSurf\bin directory of the FileSurf server.  This is required for the 
indexer. 

• Hummingbird DM must be set up to use Windows Integrated 
Authentication.  Please see appendix for instructions. 

• Any Hummingbird DM fields that you wish to map to FileSurf must be 
included on both the GROUP_DEF and DEF_PROF profiles. 

• The settings for "Allow To Check-In Other's Documents" should be set 
to "NO" at the System Level, and "Default" for all other groups except 
for DOCS_SUPERVISORS.  Only this group should be set to YES. This 
prevents users from checking in documents that have been checked 
out by the "Declare" process.  Please note that DOCS_SUPERVISORS 
will still be able to check in these documents. 

• For indexer to be able to access DM5 documents in DM5 repository, 
FileSurf Administrator account needs 'Read' access to it. 

 

3 Manual Installation 
3.1 Summary of Tasks 
The following table lists the steps of the installation as well as which 
programs are required and on which systems: 

 

# Task Server / 
Workstation 

Program(s) 
Used 

1 Add integration fields to DM 
database 

Can be run from any 
system with MS SQL 
installed and ability to 
access database server 

Microsoft Query 
Analyzer or 
Enterprise 
Manager 

2 Add FileSurf Administrator user DM Server Hummingbird DM 



 

 
FileSurf/Hummingbird DM 5 
Installation and Configuration Guide 
 

Page 5 of 41 Confidential 

 

to DM database Library 
Maintenance 

3 Add category structure to 
Hummingbird DM Database 
Corporate hierarchies only 

DM Server Hummingbird DM 
Designer 

 

4 Register Hummingbird DM 
database as a FileSurf 
Repository 

FileSurf COM 
Server 

MDY FileSurf 
Server 
Administrator 

5 Configure synchronization tools FileSurf COM 
Server 

MDY FileSurf 
Server 
Administrator 

6 Add Hummingbird DM 
repository to indexing service 

FileSurf Web server MDY FileSurf Web 
Administrator 

7 Install integration and folder 
manager 

User workstation FileSurf Client 
Setup 

3.2 On the Database Server 
Task 1:  Add the fields FileSurf uses for storage to the 
VERSIONS table of the Hummingbird DM database 
Microsoft Query Analyzer or Microsoft Enterprise Manager 

This can be done through a script entered in Microsoft Query Analyzer or 
through the interface of Enterprise Manager’s table design mode. 

Open Query Analyzer 

Log on as database owner (sa) 

Select the Hummingbird DM database from the drop-down on the toolbar  

Copy the following text into the command area: 
 

ALTER TABLE DOCSADM.VERSIONS ADD 

 [FS_CONT_ID] int NULL , 

 [FS_DATABASE] varchar(30) NULL , 

 [FS_FILE_ID] int NULL , 

 [FS_MATTER_ID] int NULL , 

 [FS_CATEGORY_ID] int NULL , 

 [FS_STATUS] varchar(1) NULL  

 

Press F5 to execute the query 

-- or -- 
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Open Enterprise Manager   

On the left pane, drill down to the Tables node under the name of the 
Hummingbird DM database, logging on as database owner (sa) if necessary. 

On the right pane, right-click the VERSION table and select Design Table 
from the menu.   

Enter the following for each field: 
 Name   Type  Allow NULL 

 FS_CONT_ID  int   YES 

 FS_DATABASE  varchar(30)  YES 

 FS_FILE_ID  int   YES 

 FS_MATTER_ID  int   YES 

 FS_CATEGORY_ID int   YES 

 FS_STATUS  varchar(1) YES 

 
Task 2:  Create FileSurf Admin user 
Hummingbird DM Library Maintenance 

Open Hummingbird DM library Maintenance if not already open.  By default, 
it can be opened by selecting Programs->Hummingbird->DM 5.1->Library 
Maintenance from the Start Menu.  Select People on left plane and select 
New from Edit menu 

The People dialog box will open 
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Enter the following information for the user FileSurf Admin 

Short Name: <FileSurf Administrator account name> 

Network ID: < The network ID of FileSurf Administrator > 

Primary Group:  DOCS_SUPERVISORS 

Full Name: <FileSurf Administrator display name> 

Click OK 

Important:  DOCS_SUPERVISORS must be allowed delete versions and to 
checkout other users’ documents 

 
Task 3: Add category structure to Hummingbird DM Database 
Hummingbird DM Designer 

 

If the FileSurf database uses a corporate (category) hierarchy and if category 
is going to be mapped, then the next step is to create a table in 
Hummingbird DM where code and title can be synched to FileSurf’s 
f_category table.  Open DM Designer by selecting Programs->Hummingbird-
>DM 5.1->DM Designer from the Start Menu. 
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Before doing anything else, make sure you are working with the correct 
library by checking the library name in the status bar.  The working library 
can be changed by clicking on Library menu. 

 

A: Create table  

Click on Database button in toolbar to bring up the fields editor: 
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Click on New Table button to bring up Table Definition dialog.  Enter 
“CATEGORY” for name and description then click OK.   

 

Click on New Column to add category code field.  Important: Do not enter 
a column name that already being used – even in another table.  
Enter “CATEGORY_CODE” for Column Name, “100” for Length, and “Category 
Code” for Prompt.  Select “Candidate” for Key?.   Here is the form with the 
values entered: 

 

 
 

Click OK. 

 

Click on New Column again to add category description field.  Enter 
“CATEGORY_DESC” for Column Name, “1000” for Length, and “Category 
Description” for Prompt.    Here is the form with the values entered: 
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Click OK.  Lookup will be populated with ‘CATEGORY’ before the dialog closes.  
Click Save Table on fields editor to save changes.   

 
 

Click Yes 
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Click OK. 

 

 
 

Click Yes.  Click Close on Select fields to edit dialog. 

 

B: Create lookup 

Click on Lookups button in toolbar to bring up Lookups ID editor.   
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Select CATEGORY and click OK.  Take the default values and click OK. 

 

C: Create form 

Click on Maintenance button in toolbar to bring up the Available Forms 
dialog: 

 

 
Select CATEGORY and click OK.  This will bring up a blank form and a list of 
fields.  Drag CATEGORY_CODE and then drag CATEGORY_DESC from the list 
of fields to the blank form and arrange as below (or however you like): 
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Close the form by clicking on the close button on the caption bar.  Click Yes 
on the dialog that asks “Do you want to save changes?”.  The following dialog 
will prompt you for a description and language code: 

 

 
 

Enter “Category” for Description and click OK. 

 

D: Add Category Fields to Standard Form(s) 

Click on Profiles button in toolbar to bring up the Available Forms dialog: 
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Select DEF_PROF (Document Profile) and click OK.  This will bring up the 
profile in designer mode: 

 
 

This profile form allows fields to be added, deleted, or moved.  First make 
room for the category fields by dragging the edge of the dialog to make it 
bigger and/or rearranging fields on the dialog.  Expand the CATEGORY entry 
in SQL Columns and drag the CATEGORY_CODE and CATEGORY_DESC 
fields5 from the SQL columns list to the Document Profile and arrange in a 
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way similar to Author or Document Type.  CATEGORY_CODE will be editable 
and with a lookup button while CATEGORY_DESC will be read-only.  For help 
with form design, consult your Hummingbird DM documentation. 

 

Repeat the process with GROUP_DEF (Default Profile for groups) and 
DEF_QBE (Search Form). 

 

E: Restart Server 

For above changes to take effect, the server must be restarted.  Open DM 
Server and under the Server State tab, click the Stop button.  When server 
status read stopped, click on Start button. 

 

F: Populate Categories 

Using FileSurf’s category lookup, enter the values full code and name values 
to the corresponding fields created in Hummingbird DM database.  Open 
Library Maintenance and select CATEGORY on the left pane.   

For each category to be added: 

• Select File->New or click on New icon to get New Category dialog box. 

• Enter the full code from FileSurf category into Category Code 

• Enter title from FileSurf category to Category Description 

• Click OK. 

 

Task 4:  Register Hummingbird DM database as a Repository 
MDY FileSurf Server Administrator 

Open FileSurf Server Administrator by selecting Programs->FileSurf-
>FileSurf Server Configuration from Start Menu 
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Expand FileSurf Repositories Node on left pane 

Right-click the FileSurf database alias underneath and select Add New 
Repository from the menu 

This will open the Repository dialog 

 
 

Enter the following data about the repository: 

Repository Type: Select DM 5 from the drop-down list 
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Description:  description should include DM library name e.g. DM library 
“DocsFusion” 

Status: Select Place from drop-down list 

Click Next > 

 
 

Enter the following data about the repository: 

DM5 Database : < Hummingbird DM library name > 

Click Next > 

 

 
 

Enter the following data about the repository: 

Office: < office location of DM database > 

Click Next > 
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View Location: Do not enter any data. 

Click Next > 

 

 
 

Enter the following data about the repository: 

Content Index Location: The location of the FileSurf’s content index for the 
Hummingbird DM database.  If not yet configured, this will be done during 
Task 6.  For now, let’s create this location and designate it a network share.   

Create a new folder in Windows Explorer - right-click the folder and select 
Properties… from the menu.  Both directory security and share permissions 
must be configured to allow access to FileSurf Administrator account only.   

For the share, click on the Sharing tab and click Share this folder.  Click 
Permissions and configure as seen in the figure on the right.   
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Click OK.  For directory security, click the Security tab and configure as seen 
in the figure below: 

 

 
Include those users that need access to content search, universal search and 
grant read-only access. 
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Click OK and return to the repository dialog to enter the share name into 
Content Index Location. 

Click Finish. 

 

Task 5:  Install Synchronization Tools 
MDY FileSurf Server Administrator 

The two synchronization utilities keep data in FileSurf and Hummingbird DM 
consistent.  The DM5 Document Synchronization tool synchronizes security 
and mapped fields of documents, while the DM5 Metadata Synchronization 
tool synchronizes groups.  When groups are synchronized, the integration 
processes are more efficient.   

Configuring DM5 Document Synchronization 

1. From the MDY FileSurf Server Administrator main form, expand Scheduled 
Jobs  

2. Select DM5 Document Synchronization on the left pane 

 

 

3. Click on the button with Folder and clock icon (circled in red above) from 
toolbar –or- right-click and select Add job from the menu.  The new job 
dialog opens… 
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4. Enter a unique name for the new job in Job Name box. 

5. Enter or select FileSurf Administrator account for Run as 

6. Click on Password… button to set the password for the FileSurf 
Administrator account 

7. Click on the Schedule tab. 

8. Select at from the Run dropdown and select a time convenient for users. 
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9. Click the FileSurf tab 

 
 

10. Select the FileSurf database from the Database dropdown 

11. Select a Log level: Errors Only, Minimal, Detailed, or Extreme.  Unless 
troubleshooting, always use Errors Only or Minimal. 
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12. To use starting time displayed, leave the checkbox next to the date/time 
checked.  If filing documents starting today, use change the displayed date 
to yesterday’s date.  If the checkbox is cleared, synchronization will use 
1/1/1900 as a start date. 

13. Click Save, then Close. 

Configuring DM5 Metadata Synchronization 

14. Select DM5 Meta Data Synchronization on the left pane of the Server 
Administrator’s main form 

 

 

15. Click the button with folder and clock icon on the toolbar –or- right-click 
and select Add Job from the menu 

16. Repeat steps 4-13 as outlined for document synchronization above.  Skip 
step 12 since Metadata synchronization does not use last date. 

 

Testing 

After installing the synchronization utilities, test them by doing the following: 

 

 

3.3 On the FileSurf Web Server 
Task 6:  Add Hummingbird DM Repository to Indexing Service 
via FileSurf Web Administrator 
MDY FileSurf Web Administrator 
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Important: For indexer to be able to access DM5 documents in DM5 
repository, FileSurf Administrator account needs 'Read' access to it. 

Open the w3FsAdm.exe program located at C:\Inetpub\FileSurf 

Select Components on the left pane, this will open the components dialog 
box 

Click on the Indexer tab 

Click on the Connect To Server button (the pointing hand icon) 

 
 
Select the FileSurf database that contains the Hummingbird DM repository 
added in Task 4. 

Check the box next to it if not checked already - a list of repositories will be 
displayed 

Right-click on the Hummingbird DM repository added in Task 4 and select 
Indexable from the menu - there will now be an LED icon displayed for the 
repository under the Index column 

Right-click on the Hummingbird DM repository added in Task 4 and select 
Concurrent from the menu - the LED icon displayed for the repository under 
the Index column will now appear to be lit. 

Assign a directory location to write the index to.  This location should be 
designated as a network share.  To assign an index to a location:  right-click 
on the repository and select Location from the menu.  This will open a dialog 
to enter the location, use the network share format and click OK. 
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Assign an amount of disk space to set aside for the index in the Maximum 
size of documents per sub-index (MB) text box.  The value 2000 will set 
aside 2 gigabytes, for example.  This amount should not exceed 8000. 

If there are documents with certain file extensions that should not be 
indexed, click on Default (in blue). The box above the repository list will be 
populated with a default list of file extensions that will not be included in the 
index.  Click on the box to edit the list. 

Force indexer to build index: Right-click on the DM 5 repository in the list 
and select Schedule->Rebuild from the menu.  An almost empty dialog box 
opens. 

Click on the Run Now button 

Schedule indexer to modify index: Right-click on the DM 5 repository in the 
list and select Schedule->Modify from the menu.  The following dialog opens: 

 
 
Select from from the dropdown and more fields are added to the dialog 

Change the fields to read from 8:00:00 AM to 6:00:00 PM every 1 hour every 
day.  It should look like the following: 
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Click OK 

Schedule indexer to delete index: Right-click on the DM 5 repository in the 
list and select Schedule->Delete from the menu.  The same almost empty 
dialog box opens. 

Select at from the dropdown and more fields are added to the dialog 

Change the fields to read at 1:00:00 AM every day.  It should look like the 
following: 
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Click OK 

 

3.4 On the client  
Task 7:  Install Integration and Folder Manager 
FileSurf Client Installation 

1. Start the FileSurf Client Setup program  

2. When prompted, enter the license information for DM 5 integration.  
You can find it in the LIC section of the fsi.ini file.  Use the serial 
number for the PowerDocs integration: 

[LIC] 

. 

. 

PowerDocs=XXXXXXXXXXXXXX 

 

3. The installation program will detect that Hummingbird DM is installed 
on the client.  On the Select Features dialog, make sure that DM5 
Integration under Hummingbird is checked: 
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4. Click Next> and proceed with the setup program. 

 
4 Configuration 
 

Integration configuration is carried out in the FileSurf Administrator within 
the desktop client.  Open FileSurf, by selecting Programs->FileSurf-
>FileSurf7 from the Start menu 

Select System->Administrator from the main menu.  Note: the user logged 
in must have administrative privilege in FileSurf to see this menu option. 

Expand Configuration in the left pane and select Documents.  There are two 
buttons on the right pane, FSCom Setup and Refresh FSCom 

Click on the FSCom Setup button, the FileSurf COM Setup dialog opens: 

  
 
Click on the DMS Integration tab 

Select DM5 from the Configured DMS list by clicking on it.  If DM5 does not 
appear on the Configured DMS list as it does above, then it must be added 
by selecting it from the dropdown just above the list and clicking on the Add 
New… button.  When you click on the button, a dialog will prompt you for the 
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Library name, user account credentials, and database user account 
credentials.  Enter the following: 

Library: Hummingbird DM library name 

Account: FileSurf Administrator account network login 

Password: FileSurf Administrator account network password 

Database/Account and Database/Password: enter a database account that 
has at least rights to read from the Hummingbird DM database – DOCSADM 
is recommended 

When everything is filled out, click the Save button. 

 

Show Profile 

On the right side of the DMS Integration tab, you can configure which 
privilege groups can see the FileSurf profile before declaring a Hummingbird 
DM document as a record.  A checked box indicates that the profile will be 
shown to users who have the corresponding privilege.  An unchecked box 
indicates that the profile will be shown to users with the corresponding 
privilege only when necessary.  The profile will be shown if there are required 
fields in the profile that are not autopopulated. 

 

Allow Create Folder 

In certain situations, the integration will actually create a FileSurf folder of a 
certain type for a specified Hummingbird document when this option is 
checked: 

• The type of the Hummingbird DM document being profiled must be 
associated (via DMS matrix – see section 4.2) to one and only one 
FileSurf document type 

• The integration does not find an eligible FileSurf folder of the 
configured type in the destination location 

   

Overwrite DMS Profile 

With this option checked, whenever filing a new version of an existing 
FileSurf document, the profile of the previous version will overwrite any 
mapped values from the Hummingbird DM profile.  When not checked, the 
user has the option to overwrite or keep the profile values from the 
Hummingbird DM document. 

Use Matrix for DMS Folders 

When not checked, the user can file a Hummingbird DM document into a 
folder of any type.  When checked, the user can only file the Hummingbird 
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DM document into folders whose types have been associated with the 
document type of the Hummingbird DM document being filed.  See section 
4.2 for more information. 

Allow Filing to a Different Parent 

When checked, a user can choose any FileSurf matter / category to be the 
parent of a Hummingbird DM document when filing it to FileSurf; otherwise, 
the user must choose a location under the current matter / category in the 
Hummingbird DM profile. 

File Versions as a Single Document 

When checked, a document with multiple versions is always filed as a single 
FileSurf document.  Each version in the Hummingbird DM document is saved 
as different version of that document.  When not checked, the user can 
choose to file each version of a Hummingbird DM document as a version of a 
single FileSurf document or as separate FileSurf documents. 

 

4.1 Fields Mapping 
4.1.1 Introduction 
When a document is declared as a record, certain attributes are 
automatically captured and copied to the FileSurf profile. This happens 
according to the mapping between Hummingbird DM and FileSurf profile 
attributes configured and stored in FileSurf.  The mapping is configured via 
the Fields Mapping dialog in the FileSurf Administrator. 

4.1.2 Mapping Fields Between FileSurf & Hummingbird 
DM 
From the DMS Integration tab of the FileSurf COM Setup dialog, click on 
Fields Mapping button to open the Fields Mapping dialog. 
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There are two lists on the Fields Mapping dialog.  The mapped fields list (on 
the left) shows the current mapping while the DM fields list (on the right) 
lists available Hummingbird DM Fields.  The fields in this list vary depending 
upon which item is selected in the mapped fields list.  <COMMENTS> comes 
from the VERSIONS table and so is bracketed.  The rest of the fields in the 
DM fields list come from the PROFILE table included in the GROUP_DEF 
profile in Hummingbird DM.   

To map a DM field to the FileSurf field selected in the mapped fields list, 
highlight the desired DM field and click the Apply button (or double-click the 
DM field).  If a field is already mapped, the field just selected will replace the 
field previously mapped. 

To remove a mapping, click the Clear button. 

To remove all mappings, click the Clear All button 

Important: To save the changes made, click Save before closing the dialog. 

Close the FileSurf COM Setup dialog by clicking OK 

Click the Refresh FSCom button to update the changes immediately. 

It is also necessary to restart the Hummingbird DM and FileSurf clients to see 
the changes. 
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Keep in mind that some fields which can be mapped, will not work correctly.  
This is true for those Hummingbird DM fields in the profile that are defined as 
tables and thus depend on valid codes for their values.  For instance, when 
mapping FileSurf author to Hummingbird DM author, AUTHOR _FULLNAME 
from FileSurf will not work unless the codes for PEOPLE in DM use full names.  
Map FileSurf’s AUTHOR_ID if codes in DM’s PEOPLE table are network names. 

 

4.2 Matrix 
4.2.1 Introduction 
 
The Matrix is used for mapping Hummingbird DM document types to FileSurf 
folder types.  When you map doctype to foldertype in the DMS matrix, you 
are allowing documents of doctype to be filed into folders of foldertype.  Via 
mapping, you can limit which document types can be filed to a particular 
folder type.  You can also specify a one-to-one relationship - a single 
document type for a particular FileSurf folder type.  In a one-to-one 
relationship, whenever a document of such a type is being profiled, FileSurf 
can automatically determine to which folder to place that document.  If no 
folder of this type exists for this parent, the integration can create a folder of 
this type.  This is all accomplished by using the DMS Matrix configuration 
dialog in the FileSurf administrator. 
 
4.2.2 Using DMS matrix to connect folders and document types 
 
Click the DMS Matrix button from the FileSurf COM Setup screen.  The 
following dialog will open: 
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If the matrix does not appear in the dialog, click the Retrieve button.  
FileSurf file types appear along the left side of the matrix while Hummingbird 
DM document types appear along the top.  A cell (like in a spreadsheet) is 
located at the intersection of each document type and file type.  Each cell can 
be mouse-clicked to toggle between a checked state and an unchecked state.  
Additionally each document type can be mouse-clicked to toggle all cells in 
that row and folder type can be mouse-clicked to toggle all cells in the 
column.  A cell that is checked means that the document type listed above 
the cell will be allowed to be filed in the file type listed to the left of the cell.  
A cell that is not checked means that the document type listed above the cell 
will not be allowed to be filed in the file type listed to the left of the cell.   
 
In the dialog above, DM documents of the type RM can be filed in folders of 
type COM, however they cannot be filed folders of any other type.  Also, 
documents of type of RM are automatically assigned to the COM folder when 
profiled. 
 
If there are many document types, the matrix can be difficult to work with.  
FileSurf can list those document types whose names start a certain way.  In 
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the Document types start with text box (next to Retrieve button), enter how 
the desired document types should start and click Retrieve. 
 
As an alternative, you can work with types in list view.  To switch to list view, 
click on the List radio button.  Before switching views, click Save if you want 
to save anything that might have been changed.  Any data already retrieved, 
as well as all changes will be cleared when switching to either view.  You 
might need to retrieve the matrix data again after switching. 
 
 

 
 
The Document Type column refers to the Hummingbird DM document type; 
the File Type column refers to the FileSurf folder type; the Allowed column is 
populated with checkboxes which signifies whether the documents of the 
corresponding document type can be filed to folders of the corresponding file 
type.  To populate the list, click the Retrieve button and the list should be 
populated with Hummingbird document types and FileSurf folder types. 
 
Important: To save the changes made, click Save before closing the dialog. 
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Close the FileSurf COM Setup dialog by clicking OK 

Click the Refresh FSCom button to update the changes immediately. 

It is also necessary to restart the Hummingbird DM and FileSurf clients to see 
the changes. 

 

Appendix A: Installing DM Extensions on 
FileSurf Server 
 

1. Open Internet Explorer on the machine hosting FileSurf server 
2. Go to CyberDOCS, http://<FusionServer>/cyberdocs 
3. Log in when prompted 
4. Click on My Options near the top-right corner of the web page 
5. Click on Optional Components tab 
6. Make sure DMEXTENSIONS is checked and click the unmarked 

install button.  It is the left-most button on the gray toolbar just 
above Available Deployment Packages 

 

 
 
7. Allow installer to run and make the following selections on the 
Select Optional Components dialog: 
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7. Click next and proceed with the installation. 
 

Appendix B: Windows Integrated Authentication in 
Hummingbird DM 
 
MDY requires that Hummingbird DM server be set up to use Integrated 
Authentication for the DM/FileSurf integration to work correctly.  Here 
is how to do it: 
 

1. Open DM Library Maintenance: Start->Hummingbird->DM 
Server->Library Maintenance 

 
2. Make sure the correct library is selected in the Library 

Maintenance toolbar, then, select File->System Parameters from 
the main menu.   
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The System Parameters dialog opens. 

 
3. Click on the Features tab: 
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Make sure that the checkbox for Accept User-Supplied 
Identification is not checked.  Click on Defaults tab: 
 

 
 
Make sure Allow Auto Logon is checked.  Click Apply or OK to 
save any changes made.   
 
Also, make sure that all groups either allow Auto logon or accept 
the global default that you just set.  Highlight groups on the left 
pane of Library Maintenance, double-click a group’s entry on the 
right pane to bring up its properties dialog, and then go to the 
Features tab: 
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Click OK or Apply to save the changes. 
 

 
Appendix C: Adding fields to the Hummingbird DM 
Profile 

 
Adding fields (especially lookups) to the Hummingbird DM profile can 
be a long and error-prone process.  Be deliberate and careful while 
adding fields to a profile.  If you make a mistake - do not delete 
anything.  This section is meant as reference, not as a tutorial.  Please 
see the Hummingbird documentation for more information about this 
process. 

 
It must first be determined what kind of field is to be added to the 
profile.  Is it a string, date, or lookup to another table?  If it is a 
lookup, follow the process as explained in Task 3: 

 
1. Add the table and fields to the database. 
2. Make sure the lookup was created when table was saved 
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3. Design the form for data of this table 
4. Add the field to profiles being used by integrations 
5. Restart server 
6. Populate data in Library Maintenance 

 
If it is not a lookup, then the field only needs to be added to the profile 
(table and form). 
 

1. Add field to the Profile table in DM Designer. 

 
 
2. Add field to the Profile using the forms designer. 
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